Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Application responding slowly
Resolved
·
Partial outage
Issue is resolved.
Wed, Aug 20, 2025, 05:57 PM
(
2
months ago)
·
View all updates
Affected components
Aug 20, 2025, 05:39 PM
05:57 PM
Encord (UK deployment)
Updates
Resolved
Issue is resolved.
Wed, Aug 20, 2025, 05:57 PM
Monitoring
The Encord application is responding slowly for some users.
Wed, Aug 20, 2025, 05:20 PM
(
37
minutes earlier)
Powered by
Privacy policy
·
Terms of service